android studio module添加最新的com.android.support:appcompat-v7:21.0.0依赖报错

我的开发平台是Mac,测试机是MX3(API 19 android 4.4.4),我不确定其他平台是否出现该问题,所以提前说明一下,免得误人子弟。

今天再使用自定义ActionBar的时候,出现了一个很奇葩的错误,就是我为自己的module添加了最新的
com.android.support:appcompat-v7:21.0.0依赖后,在Activity中使用

final ActionBar actionBar = getActionBar();
actionBar.show();

来获取ActionBar时,抛出了NullPointerException异常,这让我百思不得其解。这在之前使用一直没用问
题啊。。。。。于是,各种百度google,但是并未发现类似问题(我用了最新的support包)。最后,人品
爆发,在StackOverFlow上找到了类似的问题,后来我意识到可能是com.android.support:appcompat
-v7:21.0.0版本太高,导致在android 5.0以下的sdk导致不兼容问题。估计,google的脑袋是被枪打
了把,话说support包本就是用来做兼容的吧,在这个版本竟然成了导致不兼容的原因。。。。。

错误原因分析如下:
在module的build.gradle文件里,如果用默认的自动依赖处理方式,如图所示:
Alt text
编译时系统就会去依赖最新版的support:appcompat-v7:21.0.0 。按照之前的经验来说是不因该有问题的,但是据我的理解,目前appcompat-v7:21.0.0须使用android 5.0版本的build tool,而且build出来的程序只能在Android 5.0下运行,真屌啊。。。。我们4.4.4的用户混不下去了么???
所以解决方法也很简单:就是把appcompat-v7:21.0.0改为appcompat-v7:19.+
如下所示:

dependencies {
compile fileTree(dir: 'libs', include: ['*.jar'])
compile project(':Library')
compile 'com.android.support:support-v4:21.0.0'
compile 'com.android.support:appcompat-v7:19.+'
}

PS: 发现国内论坛并未有人记载过此问题,所以我来记录一下,权当备忘录了。其中发了很多牢骚,还请见谅,因为这个问题耽误了我三个多小时。毕竟自己实力太菜啊,哈哈,菜鸟的高手养成计划已经开始了。